Rad cap, surely? Ktm 350

Rooster

Astrids Bizatch
Joined
Jun 3, 2014
Messages
1,957
Reaction score
0
Bikes doing something a bit strange -waters coming out at pretty much normal operating temperature from the radiator overflow pipe. I put rad fluid about 1 cm over the fins, start it up, and a few seconds before the fan comes on it pisses out at least 200ml of water - must be the rad cap??

Was checking out the system as the fan stopped working, turned out to be the fuse.
 

thebob

My name is Coco
Joined
Apr 8, 2014
Messages
3,681
Reaction score
3
Could well be. What is the fluid level like once the excess stuff has been forced out? You could be overfilling it slightly or there could be air in the system. I have a spare 1.8 bar cap you can borrow to see if it fixes the issue. Let me know if you want to try it.
 

Rooster

Astrids Bizatch
Joined
Jun 3, 2014
Messages
1,957
Reaction score
0
Once done it is way below the fins and needs another 200 ml.... I fill it to just over the fins as per manual. I think I sorted it though - opened the drain bolt again to check for bubbles, then ran it with the cap off for 5 minutes. Tested ok after that. Will test again tomorrow, I think (hope) I just got a big air bubble in the system causing pressure. Thanks for the offer, may take you up on that if it's not sorted.
 

Pom17

I like trying to get my 4T to lift the front. Soon
Joined
Aug 25, 2014
Messages
2,705
Reaction score
5
Rooster, also check, I once had a little piece of dirt stuck behind the rubber of the radiator cap which prevented the thing from sealing properly and it pissed water for no reason. Might not be it but worth the check
 

Rooster

Astrids Bizatch
Joined
Jun 3, 2014
Messages
1,957
Reaction score
0
Will do thanks - cleaned the front, didn't check behind
 
Top